锐捷交换机配置常用及终极命令

原创 wwc  2019-07-09 22:01:38  阅读 68 次 评论 0 条

timg.jpg

准备命令

>Enable     进入特权模式
#Exit     
返回上一级操作模式
#End     
返回到特权模式
#write memory或copy running-config startup-config     
保存配置文件
#del flash:config.text  
   删除配置文件
#erase startup-config     
删除配置文件
#del flash:vlan.dat     
删除Vlan配置信息
#Configure terminal     
进入全局配置模式
(config)#hostname switchA     
配置设备名称为switchA
(config)#banner motd &     
配置每日提示信息 &为终止符
(config)#enable secret level 1 0 star     
配置远程登陆密码为star
(config)#enable secret level 15 0 star    
 配置特权密码为star
Level 1为普通用户级别,可选为1~15,15为最高权限级别;0表示密码不加密
(config)#enable services web-server     
开启交换机WEB管理功能
Services可选以下:web-server(WEB管理)、telnet-server(远程登陆)等

查看信息

#show running-config     查看当前生效的配置信息
#show interface fastethernet 0/3     
查看F0/3端口信息
#show interface serial 1/2     
查看S1/2端口信息
#show interface     
查看所有端口信息
#show ip interface brief     
以简洁方式汇总查看所有端口信息
#show ip interface     
查看所有端口信息
#show version     
查看版本信息
#show mac-address-table     
查看交换机当前MAC地址表信息
#show running-config     
查看当前生效的配置信息
#show vlan     
查看所有VLAN信息
#show vlan id 10     
查看某一VLAN (如VLAN10)的信息
#show interface fastethernet 0/1 switchport     
查看某一端口模式(如F 0/1)
#show aggregateport 1 summary     
查看聚合端口AG1的信息
#show spanning-tree     
查看生成树配置信息
#show spanning-tree interface fastethernet 0/1     
查看该端口的生成树状态
#show port-security     
查看交换机的端口安全配置信息
#show port-security address    
 查看地址安全绑定配置信息
#show ip access-lists listname     
查看名为listname的列表的配置信息

端口的基本配置

(config)#Interface fastethernet 0/3     进入F0/3的端口配置模式
(config)#interface range fa 0/1-2,0/5,0/7-9     
进入F0/1、F0/2、F0/5、F0/7、F0/8、F0/9的端口配置模式
(config-if)#speed 10     
配置端口速率为10M,可选10,100,auto
(config-if)#duplex full     
配置端口为全双工模式,可选full(全双工),half(半双式),auto(自适应)
(config-if)#no shutdown     
开启该端口
(config-if)#switchport access vlan 10     
将该端口划入VLAN10中,用于VLAN
(config-if)#switchport mode trunk     
将该端口设为trunk模式,用于Tag vlan,可选模式为access,trunk
(config-if)#port-group 1     将该端口划入聚合端口AG1中,用于聚合端口

聚合端口的创建

(config)#interface aggregateport 1     创建聚合接口AG1
(config-if)#switchport mode trunk     配置并保证AG1为trunk模式
(config)#int f0/23-24
(config-if-range)#port-group 1    
 将端口(端口组)划入聚合端口AG1中

生成树

(config)#spanning-tree     开启生成树协议
(config)#spanning-tree mode stp     
指定生成树类型为stp,可选模式:stp、rstp、mstp
(config)#spanning-tree priority 4096     
设置交换机的优先级为4096 , 优先级值小为高。优先级可选值为0,4096,8192,……,为4096的倍数。交换机默认值为32768

VLAN的基本配置

(config)#vlan 10     创建VLAN10
(config-vlan)#name vlanname     命名VLAN为vlanname
(config-if)#switchport access vlan 10     
将该端口划入VLAN10中
某端口的接口配置模式下进行
(config)#interface vlan 10     进入VLAN 10的虚拟端口配置模式
(config-if)#ip address 192.168.1.1 255.255.255.0     为VLAN10的虚拟端口配置IP及掩码,二层交换机只能配置一个IP,此IP是作为管理IP使用,例如,使用Telnet的方式登录的IP地址
(config-if)#no shutdown     
启用该端口

端口安全

(config)#interface fastethernet 0/1     进入一个端口
(config-if)#switchport port-security     
开启该端口的安全功能

配置最大连接数限制:
(config-if)#switchport port-secruity maxmum 1     配置端口的最大连接数为1,最大连接数为128
(config-if)#switchport port-secruity violation shutdown     
配置安全违例的处理方式为shutdown,可选为protect (当安全地址数满后,将未知名地址丢弃)、restrict(当违例时,发送一个Trap通知)、shutdown(当违例时将端口关闭,并发送Trap通知,可在全局模式下用errdisable recovery来恢复)

IP和MAC地址绑定:
(config-if)#switchport port-security mac-address xxxx.xxxx.xxxx ip-address 172.16.1.1     
接口配置模式下配置MAC地址xxxx.xxxx.xxxx和IP172.16.1.1进行绑定(MAC地址注意用小写)

三层路由功能(针对三层交换机)

(config)#ip routing     开启三层交换机的路由功能
(config)#interface fastethernet 0/1    
(config-if)#no switchport     
开启端口的三层路由功能(这样就可以为某一端口配置IP)
(config-if)#ip address 192.168.1.1 255.255.255.0 
(config-if)#no shutdown 

三层交换机路由协议

(config)#ip route 172.16.1.0 255.255.255.0 172.16.2.1     配置静态路由
:172.16.1.0 255.255.255.0为目标网络的网络号及子网掩码
172.16.2.1为下一跳的地址,也可用接口表示,如ip route 172.16.1.0 255.255.255.0 serial 1/2(172.16.2.0所接的端口)
(config)#router rip     开启RIP协议进程
(config-router)#network 172.16.1.0     申明本设备的直连网段信息
(config-router)#version 2     开启RIP V2,可选为version 1(RIPV1)、version 2(RIPV2) 
(config-router)#no auto-summary     关闭路由信息的自动汇总功能(只有在RIPV2支持)
(config)#router ospf     开启OSPF路由协议进程(针对不同系列,可能需要加OSPF进程ID)
(config-router)#network 192.168.1.0 0.0.0.255 area 0     
申明直连网段信息,并分配区域号(area0为骨干区域)

IP ACL

交换机采用命名的访问控制列表;分标准(stand)和扩展(extended)两种

标准ACL:
(config)#ip access-list stand listname     定义命名标准列表,命名为listname,stand为标准列表
(config-std-nacl)#deny 192.168.30.0 0.0.0.255     
拒绝来自192.168.30.0网段的IP流量通过
:deny:拒绝通过;可选:deny(拒绝通过)、permit(允许通过)
192.168.30.0 0.0.0.255:源地址及源地址通配符;可使用any表示任何IP
(config-std-nacl)#permit any
(config-std-nacl)#end     
返回

扩展ACL:
(config)#ip access-list extended listname     定义命名扩展列表,命名为listname,extended为扩展
(config-ext-nacl)#deny tcp 192.168.30.0 0.0.0.255 192.168.10.0 0.0.0.255 eq www     
拒绝源地址为192.168.30.0网段的IP访问目的地址为192.168.10.0网段的www服务
:deny:拒绝通过,可选:deny(拒绝通过)、permit(允许通过)
tcp:协议名称,协议可以是udp、ip、eigrp、gre、icmp、igmp、igrp等等。
192.168.10.0 0.0.0.255:源地址及源地址通配符
192.168.30.0 0.0.0.255:目的地址及目的地址通配符
eq:操作符(lt-小于,eq-等于,gt-大于,neg-不等于,range-包含)
www:
端口号,可使用名称或具体编号
(config-ext-nacl)#permit ip any any     允许其它通过
(config-ext-nacl)#end     返回
(config)#interface vlan 10     进入端口配置模式
(config-if)#ip access-group listname in     访问控制列表在端口下in方向应用;可选:in(入栈)、out(出栈)
(config-if)#end     
返回
:配置ACL时,若只想对其中部分IP进行限制访问时,必须配置允许其流量通过,否则设备只会对限制IP进行处理,不会对非限制IP进行允许通过处理。

是真的骚这波不亏哈哈哈哈哈哈哈啊哈哈哈啊哈哈哈tm竟然看懂了一条这不科学我的屠龙宝刀呢嚯嚯嚯嚯嚯友情提示:实在坚持不住的请直接翻到末尾,没什么见不得人的皮皮虾,来接你的主人,他说要走想静静思考一下是谁给了我勇气点进来6666666


配置命令示例

交换机密码
(config)#enable secret level 1 0 100
(config)#enable secret level 15 0 100

远程登入密码
(config)#line vty 0 4
(config-line)#password 100
(config-line)#end

交换机管理IP
(config)#interface vlan 1
(config-if)#ip address 192.168.1.10 255.255.255.0
(config-if)#no shutdown

修改交换机老化时间
(config)#mac-address-table aging-time 20
(config)#end

添删vlan
(config)#vlan 888
(config-vlan)#name a888
(config)#no vlan 888

添加access口
(config)#interface gigabitEthernet 0/10
(config-if)#switchport mode access
(config-if)#switchport access vlan 10

切换assess trunk
(config-if)#switchport mode access
(config-if)#switchport mode trunk

指定特定一个native vlan
(config-if)#switchport trunk native vlan 10

配置trunk口的许可vlan列表
(config-if)#switchport trunk allowed vlan ?
add   Add VLANs to the current list
all   All VLANs
except All VLANs except the following
remove Remove VLANs from the current list

速成树协议
(config)#spanning-tree
(config)#spanning-tree mode rstp/stp

配置网关
(config)#ip default-gateway 192.168.1.254 

查看CPU利用率
show cpu

查看交换机时钟
show clock 

查看交换机日志
show logging 

查看交换机动态学习到的MAC地址表   
show mac-address-table dynamic 

查看当前交换机运行的配置文件
show running-config 

查看交换机硬件、软件信息
show version

查看交换机的arp表
show arp

显示接口详细信息的命令
show interfaces gigabitEthernet 4/1 counters

接口配置
Switch(config)#interface gigabitethernet 0/1 

把接口工作模式改为光口
Switch(config-if)#medium-type fiber

把接口工作模式改为电口
Switch(config-if)#medium-type copper

速度/双工配置
进入接口配置模式
Switch(config)#interface interface-id
设置接口的速率参数,或者设置为auto
Switch(config-if)#speed {10 | 100 | 1000 | auto }    
设置接口的双工模式
Switch(config-if)#duplex {auto | full | half} 

例子
Switch(config)#interface gigabitethernet 0/1 
Switch(config-if)#speed 1000
Switch(config-if)#duplex full 
光口不能修改速度和双工配置,只能auto
在故障处理的时候,如果遇到规律性的时断时续或掉包,在排除其他原因后,可以考虑是否和对端设备的速率和双工模式不匹配,尤其是两端设备为不同厂商的时候

VLAN
建立VLAN 100
Switch(config)#vlan 100
该VLAN名称为ruijie
Switch(config)#name ruijie
将交换机接口划入VLAN 中
range表示选取了系列端口1-48,这个对多个端口进行相同配置时非常有用
Switch(config)#interface range f 0/1-48 
将接口划到VLAN 100中
Switch(config-if-range)#switchport access vlan 100   
将接口划回到默认VLAN 1中,即端口初始配置
Switch(config-if-range)#no switchport access vlan 
Switch(config)#interface fastEthernet 0/1
该端口工作在access模式下
Switch(config-if)#switchport mode access   
该端口工作在trunk模式下
Switch(config-if)#switchport mode trunk    
Switch(config)#interface fastEthernet 0/2
设定VLAN要修剪的VLAN
Switch(config-if)#switchport trunk allowed vlan remove 2-9,11-19,21-4094
取消端口下的VLAN修剪
Switch(config-if)#no switchport trunk allowed vlan

生成树
开启生成树协议
Switch(config)#spanning-tree
禁止生成树协议
Switch(config)#no spanning-tree
配置生成树优先级
配置设备优先级为4096
Switch(config)#spanning-tree priority 4096   
数值越低,优先级别越高

端口镜像
配置G0/2为镜像端口
Switch(config)#monitor session 1 destination interface G 0/2
配置G0/1为被镜像端口,且出入双向数据均被镜像
Switch(config)#monitor session 1 source interface G 0/1 both
去掉镜像1
Switch(config)#no monitor session 1 

端口聚合
Switch(config)#interface fastEthernet 0/1
把端口f0/1加入到聚合组1中
Switch(config-if)#port-group 1
把端口f0/1从聚合组1中去掉
Switch(config-if)#no port-group 1

ACL
建立ACL访问控制列表名为ruijie,exten表示建立的是扩展访问控制列表
Switch(config)#Ip access-list exten ruijie
禁止PING IP地址为192.168.1.1的设备
Switch(config-ext-nacl)#deny icmp any 192.168.1.1 255.255.255.0 
禁止端口号为135的应用
Switch(config-ext-nacl)#deny tcp any any eq 135
禁止协议为www的应用
Switch(config-ext-nacl)#deny udp any any eq www 
允许所有行为
Switch(config-ext-nacl)#permit ip any any
将ACL应用到具体的接口上
Switch(config)#interface range f 0/1
把名为ruijie的ACL应用到端口f 0/1上
Switch(config-if)#ip access-group ruijie in 
从接口去除ACL
Switch (config-if)#no ip access-group ruijie in     
删除名为ruijie的ACL
Switch(config)#no Ip access-list exten ruijie 
增加ACE项后,是增加到ACL最后,不可以中间插入,如果要调整ACE的顺序,必须整个删除ACL后再重新配置

端口安全
Switch(config)#interface range f 0/1
开启端口安全
Switch(config-if)#switchport port-security 
关闭端口安全
Switch(config-if)#no switchport port-security
设置端口能包含的最大安全地址数为8
Switch(config-if)#switchport port-security maximum 8 
在接口fastethernet0/1配置一个安全地址00d0.f800.073c,并为其绑定一个IP地址192.168.1.1 
Switch(config-if)#switchport port-security mac-address 00d0.f800.073c ip-address 192.168.1.1
删除接口上配置的安全地址
Switch(config-if)#no switchport port-security mac-address 00d0.f800.073c ip-address 192.168.1.1    

防ARP攻击
IP和MAC地址的绑定
Switch(config)#arp ip-address hardware-address [type] interface-id
Switch(config)#arp 192.168.12.111 00d0.f800.073c arpa g 0/1
绑定网关
进入指定端口进行配置
Switch(config)#Interface interface-id
配置防止ip-address的ARP欺骗
Switch(config-if)#Anti-ARP-Spoofing ip ip-address

防STP攻击
进入端口Fa0/1
Switch(config)#inter fastEthernet 0/1 
打开该端口的的BPDU guard功能
Switch(config-if)#spanning-tree bpduguard enable 
关闭该端口的的BPDU guard功能
Switch(config-if)#spanning-tree bpduguard diaable
端口关闭后只能shutdown然后再no shutdown或者重新启动交换机才能恢复

防DOS/DDOS攻击
进入端口Fa0/1
Switch(config)#inter fastEthernet 0/1 
预防伪造源IP的DOS攻击的入口过滤功能
Switch(config-if)#ip deny spoofing-source
关闭入口过滤功能只能在三层接口上配置
Switch(config-if)#no ip deny spoofing-source
和ACL不能同时存在
端口关闭后只能shutdown然后再no shutdown或者重新启动交换机才能恢复

防IP扫描攻击
打开系统保护
Switch(config)#system-guard enable
关闭系统保护功能
Switch(config)#no system-guard

DHCP
打开DHCP Relay Agent
Switch(config)#service dhcp 
配置DHCP Server的IP地址
Switch(config)#ip helper-address address

VRRP
Switch(config)#Interface interface-id    
Switch(config-if)#Standby [group-number] ip ip-address 
设置虚拟机的优先级
standby [group-number] priority priority 

三层交换机配置
SVI:
把VLAN 10配置成SVI
switch(config)#interface vlan 10
给该SVI接口配置一个IP地址
switch(config-if)#ip address 192.168.1.1 255.255.255.0 
Routed Port:
switch(config)#interface fa 0/1
把f 0/1变成路由口
switch(config-if)#no switch 

路由配置
添加一条路由
switch(config)#ip route     目的地址 掩码 下一跳

switch(config)#ip route 210.10.10.0 255.255.255.0 218.8.8.8

冗余链路
在骨干网设备连接中,单一链路的连接很容易实现,但一个简单的故障就会造成网络的中断。因此在实际网络组建的过程中,为了保持网络的稳定性,在多台交换机组成的网络环境中,通常都使用一些备份连接,以提高网络的健壮性、稳定性。
这里的备份连接也称为备份链路或者冗余链路。备份链路之间的交换机经常互相连接,形成一个环路,通过环路可以在一定程度上实现冗余。
链路的冗余备份能为网络带来健壮性、稳定性和可靠性等好处,但是备份链路也会使网络存在环路,环路问题是备份链路所面临的最为严重的问题,交换机之间的环路将导致网络新问题的发生:广播风暴、多帧复制、地址表的不稳定。

解决方法:生成树协议避免环路
每个LAN都会选择一台设备为指定交换机,通过该设备的端口连接到根,该端口为指定端口(Designated port)
将交换网络中所有设备的根端口(RP)和指定端口(DP)设为转发状态(Forwarding),将其他端口设为阻塞状态(Blocking)
生成树经过一段时间(默认值是50秒左右)稳定之后,所有端口要么进入转发状态,要么进入阻塞状态

IEEE 802.1w快速生成树协议概述
快速生成树协议RSTP(Rapid Spannning Tree Protocol) IEEE 802.1w在STP协议基础上做了改进,使得收敛速度快得多(最快1秒以内)

生成树协议的配置
开启生成树协议
Switch(config)#Spanning-tree
关闭生成树协议
Switch(config)#no Spanning-tree
配置生成树协议的类型
Switch(config)#Spanning-tree mode stp/rstp
配置交换机优先级
Switch(config)#spanning-tree priority <0-61440> 
(“0”或“4096”的倍数、共16个、缺省32768)
恢复到缺省值
Switch(config)#no spanning-tree priority
配置交换机端口的优先级
Switch(config)#interface interface-type interface-number
Switch(config-if)#spanning-tree port-priority number
显示生成树状态
Switch#show spanning-tree
显示端口生成树协议的状态
Switch#show spanning-tree interface fastethernet <0-2/1-24>

生成树协议(spanning-tree protocol)由IEEE 802.1d标准定义。生成树协议的作用是为了提供冗余链路,解决网络环路问题。生成树协议通过SPA(生成树算法)生成一个没有环路的网络,当主要链路出现故障时,能够自动切换到备份链路,保证网络的正常通信。


本文地址:https://www.wwc-blog.com/post/396.html
版权声明:本文为原创文章,版权归 wwc 所有,欢迎分享本文,转载请保留出处!

发表评论


表情

还没有留言,还不快点抢沙发?